LV. 19
GP 84

【心得】一些關於MOD安裝的必要工具程式

樓主 闇黑神騎士 andytsai1973
GP88 BP-
最近看到有很多新朋友開始玩上古5, 也開始有很多人跳進mod這個無底洞.

相信大家都有爬文, 但是總會看到很多人在問
1. 為甚麼裝了mod之後, 人物動不了?
2. 要怎麼檢查mod有沒有衝突?
3. 甚麼是FNIS跟SKSE?
4. 要怎樣幫mod排順序

我在這裡簡單介紹一些有關mod的基本必要工具
其實這些內容在版上爬文都能找到答案, 但是我把它們彙整起來

上古5如果要加裝mod, 特別是你要裝很多mod或是純粹只是想試用看看, 以下的工具程式是不可少的

1. Skyrim Script Extender (SKSE) 天際腳本擴張

正如同它的文字敘述, 如果你加裝的mod裡頭, 有 Script檔案夾的話, 你就必須用SKSE loader來啟動遊戲, 不然Script檔案夾內的資料不會發生作用. 輕則就是這個mod不起作用, 重則就是遊戲當了, 甚至可能損毀到紀錄檔. 由於大學漢化中有使用到Script檔案夾, 因此也必須用SKSE啟動, 不過就不需要用Micro AppLocale

點選連結後, 下載SKSE程式, 現在最新版為skse_1_06_16, 將檔案解壓縮後, 把內容全部複製貼到C:\Program Files (x86)\Steam\SteamApps\common\Skyrim 內, 然後就可以用檔案夾內的skse_loader(可以傳到桌面當捷徑)啟動遊戲


或是經由NMM左上角啟動



2. Fores New Idles in Skyrim - FNIS

這是所有有更動到人物動作所必須的工具檔案, 只要是有動作的mod, 不論是走路或是跑步動作變更, 骨架變更, 18禁, 新的終結技, 新的動作包. 都必須用FNIS
點入上頭的連結後, 選檔案, 可以看到兩個檔

都要安裝. 安裝後, 進入
C:\Program Files (x86)\Steam\SteamApps\common\Skyrim\Data\tools\GenerateFNIS_for_Users
會看到一個橘色的應用程式-GenerateFNISforUsers

 
執行這個檔案, 它會在桌面建立捷徑. 日後只要有裝新的mod, 都建議用GenerateFNISforUsers跑一遍. 這程式執行的畫面是這樣

先選擇語言為繁體中文, 接著把底下6個選項的最上面兩個勾選. 然後按下更新FNIS行為
執行後, 應該是這樣

再檢查一致性, 沒有任何錯誤就可以按退出了. 這就是所謂用FNIS跑一遍

3. Wrye Bash
這是一個功能強大的工具程式, 用途非常多. 但在這裡僅介紹它的基本功能-檢查mod是否有衝突
先進入連結, 然後下載程式, 請注意, 這程式不能用NMM下載安裝, 必須手動安裝
下載後, 會得到一個程式 Wrye Bash 304 - Installer, 點選執行

然後就一直按Next. 直到安裝完畢
接著進入C:\Program Files (x86)\Steam\SteamApps\common\Skyrim\
會找到一個新的檔案夾 - MOPY, 打開後, 裡頭有個應用程式-Wrye Bash(可以將它傳送到桌面上建立捷徑), 點選執行後(這是我的mod檔案)

如果都顯示綠色, 那代表安裝的mod並無衝突. 如果有紅色的, 那就是有衝突, 可能必須排序或是移除不要用有問題的mod

4. BOSS

這是用來排序mod的工具. 如果你裝了很多mod(50個以上), 建議都要用BOSS排序,
點選連結後, 會看到這個畫面
要注意的是, BOSS的下載檔不在[Files], 而是在[MIRRORS]. 這也不能用NMM下載安裝
手動下載後, 會得到BOSS v2.1.1 Installer這個檔案, 點選安裝後
可以在桌面左下的window程式列找到執行檔

點選後, 會看到這個小視窗, 點選執行BOSS

執行後, 會開啟一個新網頁顯示排序結果

有錯誤或是有問題警告的會顯示
進入已識別的mod項目, 如果有警告發生, 也可以找到修補連結

你可以點進去找需要修補或是更新的檔案

BOSS的載點 boss

88
-
LV. 13
GP 130
2 樓 花生夾心酥 geuo74982
GP0 BP-


抱歉= =

我是真的不會用

要怎麼讓他檢測我裝的mod有沒有衝突呢QQ
0
-
LV. 18
GP 8
3 樓 御之魂 b5b4b3b2b11
GP0 BP-
我裝了FNIS之後  去點你那邊橘色程式  可是他都會跑出一格視窗來
這個
0
-
LV. 23
GP 157
5 樓 孤獨劍聖 a00147
GP0 BP-

※ 引述《andytsai1973 (闇黑神騎士)》之銘言

> 2. Fores New Idles in Skyrim - FNIS
 
高手請問一下 這是甚麼狀況  ~~~ 感激不盡
 

0
-
LV. 10
GP 8
6 樓 cuckold cuckold
GP0 BP-
補充一下,還有一個Script Dragon,性質類似SKSE,二者可以共用.
http://alexander.sannybuilder.com/skyrim/scriptdragon/
這五個裝齊了,基本上就沒有缺了,99.9%的MOD用到的額外插件就是這些.

剩下0.01%的例外就是如果你要玩ENB(or injector),那就還有額外的東西要裝...
http://www.enbdev.com/index_en.htm
但我真心不推薦用ENB...真心不推薦!
我自認英文程度是相當好的,目前都是直接玩英文版.可是那個ENB的安裝說明,我弄了大半天,還是沒有信心....這是我目前為止唯一不敢貿然安裝的東西,因為真的很複雜.

我目前使用的光影模組是RCRN -- HDR Lighting and Weather Enhancement(3.6)
http://www.rcrncommunity.com/
真的,這個可以大幅度的美化遊戲中的光影效果.而且你在遊戲中可以直接按Pause鍵去開啟或是暫停RCRN.你立刻就可以看出RCRN的光影效果比起原始內建的真是棒多了!
安裝更是簡單,它有提供全自動化的一鍵安裝程式,連Mod Manager都免了.
真的很建議大家試試看這個光影模組吧!
好像離題太遠了....
0
-
LV. 9
GP 0
7 樓 t77741122
GP0 BP-
不好意思請問一下...要下載這些工具 FNIS 那個網站是不是要有帳號才能下載壓??
去註冊的話,我看需要錢才能註冊說..
我是剛接觸上古卷軸5的新手(玩兩天而已)...想開始載MOD玩了@@ 拜託大大幫忙

註冊好了..0.0 原來最下面那個選了不用錢就能註冊了!!
0
-
LV. 23
GP 449
8 樓 織田信長 kagato
GP0 BP-
不好意思請教一下
目前我是用NMM然後土法煉鋼一個個安裝測試是否有衝突
看過你的文章後想試試看
目前有幾個問題
BOSS只能排序 檢查衝突得用Wrye Bash
那NMM還需要安裝嗎?
還是用Wrye Bash取代NMM?
看回文好像還需要裝個MO來管理BOSS跟Wrye Bash?
是要裝哪些才夠啊?
0
-
LV. 10
GP 10
9 樓 cuckold cuckold
GP1 BP-
※ 引述《kagato (織田信長)》之銘言
> 不好意思請教一下
> 目前我是用NMM然後土法煉鋼一個個安裝測試是否有衝突
> 看過你的文章後想試試看
> 目前有幾個問題
> BOSS只能排序 檢查衝突得用Wrye Bash
> 那NMM還需要安裝嗎?
> 還是用Wrye Bash取代NMM?
> 看回文好像還需要裝個MO來管理BOSS跟Wrye Bash?
> 是要裝哪些才夠啊?

我個人覺得NMM的使用者介面比WB來的要好上手多了,非常簡單,三分鐘就可以上手.
WB的功能是強大許多,也因此那個UI看起來實在是....非常亂....
所以我主要是用NMM搭配BOSS,這個已足夠應付99%以上的需求.
我目前裝了快100個MOD,只有一個是透過WB安裝的,因為作者只提供BAIN格式.

至於BOSS提供的衝突資訊...參考即可,絕大部分都可以忽略.
就算你沒裝任何MOD,只裝了原廠的主程式和資料片,用BOSS時它一樣會告訴你有衝突...
1
-
LV. 1
GP 23
10 樓 Nocturne tony4481
GP1 BP-
BOSS是用來處理.esp Loading Order的程式
安裝任何一個MOD之後務必使用BOSS
Wrye Bash則是用來處理MOD安裝順序的

Wrye Bash 所謂的衝突是指是否有不同壓縮檔中有重複的檔案
例如有些相同的衣服,有著不同的身形,mesh檔案就會不同

BOSS所謂的衝突提示通常都是BOSS masterlist裡面
其他玩家提交的,可能是ITM或UDR,需要TES5edit清理

Wrye Bash安裝頁中,綠色就是目前檔案完全一樣
淺橘色是esp以外的檔案目前有些不符合,深橘色是指esp檔案不符合
可以看conflict或mismatch頁面尋找

Wrye Bash的MOD頁的好處就是若有缺少master的esp,WB會自動把它取消
不然一進遊戲就會當掉

NMM和WB最大的不同只在於WB有安裝檔順序的管理
舉例來說,若某套衣服有兩包不同顏色的材質,假若把其中一包材質移除
NMM會把整個相關的Texture刪掉,會造成沒有材質的問題
Wrye Bash透過順序優先性來解決就好,移除了也會把順位較後面的檔案補上去

1
-
LV. 21
GP 27
11 樓 廢柴 flame4141
GP0 BP-
所以說boss排序的可信度到底是?

這幾天開始使用boss.因為我的mod沒超過50個過
boss有標明無法辨識的檔案就自己想辦法排序.這部分自己倒是沒甚麼問題
搭配tesv5清潔檔案.boss+tesv5兩個派和使用.然後開新存檔完好像有變順暢一些
爬了不少網站資料
都有兩種說法.相信boss.以及不要全部相信boss
以mod製造者的建議排序下去排mod才正確.可是英文又看不太懂
0
-
LV. 19
GP 2
12 樓 あがスバ a0007873051
GP0 BP-
我用了後 MOD欄裡顯示都ESP綠色ESM藍色都正常沒有紅色但是我穿Witch Of The Wild卻會跳出 怪了沒衝突怎又會跳出 安裝選的是unpb啊...
0
-
LV. 8
GP 87
13 樓 經典老搖滾 ze801020
GP0 BP-
請問一下第二項Fores New Idles in Skyrim - FNIS     那兩個檔我都下載了   可是要怎麼安裝.....因為壓索檔裡面只有記事本跟Data這兩樣   我不知道要怎麼安裝   求解謝謝
0
-
LV. 1
GP 517
14 樓 小G kuso0169
GP0 BP-
我很想說就是...其實MODDER本身都不太會使用工具程式來管理MOD
原因版上資深的MODDER(台灣有嗎?QQ)大概都知道,BOSS就是一個例子
哪那些東西更改那些地方下載前看作者的敘述就能知道了,這樣自己就能判斷衝突性
不放心使用CK打開來看也行。

對MODDER來說 自己的判斷絕對好過靠工具程式
0
-
LV. 4
GP 0
16 樓 SlE蓶荿 zc8981845
GP0 BP-
都已經照步驟安裝好了 最後怎麼會變成這樣TT


0
-
未登入的勇者,要加入 17 樓的討論嗎?
板務人員:

2940 筆精華,昨天 更新
一個月內新增 10
歡迎加入共同維護。


face基於日前微軟官方表示 Internet Explorer 不再支援新的網路標準,可能無法使用新的應用程式來呈現網站內容,在瀏覽器支援度及網站安全性的雙重考量下,為了讓巴友們有更好的使用體驗,巴哈姆特即將於 2019年9月2日 停止支援 Internet Explorer 瀏覽器的頁面呈現和功能。
屆時建議您使用下述瀏覽器來瀏覽巴哈姆特:
。Google Chrome(推薦)
。Mozilla Firefox
。Microsoft Edge(Windows10以上的作業系統版本才可使用)

face我們了解您不想看到廣告的心情⋯ 若您願意支持巴哈姆特永續經營,請將 gamer.com.tw 加入廣告阻擋工具的白名單中,謝謝 !【教學】